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In this eBook you’ll find 10 Essential InDesign Skills for creating any 

document in Adobe InDesign. you can keep the tips here handy as a 

checklist for whatever InDesign project you’re working on.
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1
Prep for print in advance

Before you even create a New Document in 
InDesign, you should consider the end result. 

What are you creating? Is it a book, brochure, 

newsletter, magazine? Will the document be printed 

in-house (i.e. on a basic pC printer) or will you be 

sending the document to a professional printer? 

If you’re creating a print document for professional 

litho or digital printing, the printer will usually expect 

you, the designer, to prepare a document that is print-

ready. this saves time and money, and also means that 

you effectively ‘lock’ your pDF print file once it’s sent 

on to the printer. nobody can dip into your InDesign 

file and alter anything you wouldn’t want them to, 

mistakenly or otherwise.

You should consider how your print-ready file should 

be prepared before you create a new Document in 

InDesign. You may want to get in touch with your 

printer before starting work to check their preferences 

for print-ready files. You can check a few things when 

you create your document to ensure you’ll end up with 

a print-ready document, prepped for export (see Page 13):

Open inDesign and either select new Document from 

the Welcome window, or go to File > new > Document 

from the menu at the top of your screen.

In the new Document window, ensure the intent is set 

to Print. 

You should also be sure to enter values for the Bleed if 

your document will have any colors, images, shapes or 

other elements which will cross the edge (trim) of the 

Page. 

the Bleed is an extra space beyond the edge of 

the page which acts as a margin of error when the 

document is trimmed. to avoid a visible white line 

along the edge of your document, you should always 

include a bleed.

If you are creating a document where all the edges 

of the page will be visible on the final product (e.g. 

a poster, a business card or a folded brochure) you 

should set a bleed on all sides. If your document has 

an edge that will not be visible (e.g. a bound book, 

where the inside edge will be sucked into the binding), 

you should set a bleed on all sides except the inside 

edge. 
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2
Page number your Masters

If you’re creating a document which is 
moderately lengthy, like an Annual report, or 
very long, like a book, you should apply Page 
Numbers. the most efficient way to do this is to 
add them to a Master Page. 

We all like to be organized, so help the readers of your 

document find their way around with ease by including 

a simple numbering system.

First, you’ll need to set up a Master Page. 

You’ll notice in the Masters Panel (which sits at the 

top of the Pages Panel, go to Window > Pages to 

open) that there is already a default Master page, 

called A-Master, which was created along with your 

new document. that’s useful! We can apply our page 

numbers to that. 

Double-click the page icon to the right of the A-Master 

name to bring up the Master Page on screen. If your 

document had Facing Pages checked in the new 

Document window, there will be two pages forming a 

facing spread. If not, there will just be a single page.

Select the type tool (t) from the tools panel (Window 

> tools) and drag to create a small text frame. position 

this at the bottom of the page, centrally on a single-

page spread, or in opposing corners on a facing spread.

With your cursor sitting in the text frame, go to the top 

menu and type > insert special Character > Markers 

> Current Page number. a default A character will 

appear in the frame. 

You can apply formatting to your page number marker 

using the options available to you in the Character 

Formatting Controls panel (see page 6). Once you’ve 

done that you can apply the Master to pages in your 

document. all pages with the Master applied to them 

will show the relevant page number.

to apply the Master to individual pages, drag and drop 

the Master’s page icon in the Pages Panel, dropping 

the icon onto the relevant page icon within the same 

panel.

to apply to a group of pages, click on the group of 

three bars at the top-right of the Pages Panel to open 

a drop-down menu. Select apply Master to Pages... 

and enter your desired page range in the apply Master 

window. 
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3
typography basics

InDesign offers a number of options for setting 
typography formatting and ensuring your 
text styling stays consistent throughout your 
document. 

Once you’ve created a text frame using the type tool 

(t) and inserted text into the frame you can begin to 

define the formatting. at first, just set the formatting 

for the first paragraph of your text.

the first feature to note is the Character Formatting 

Controls. this panel runs along the top of your screen 

and will appear by default when you open InDesign (or 

go to Window > Control to open). 

From here you can set the Font, Font Weight (Regular, 

Bold, Italic etc), sizing, leading (space between lines 

of text), and text Color, as well as more advanced 

settings like Drop Cap number of lines, indents, 

kerning (the space between two individual characters) 

and tracking (adjusts the space between characters 

uniformly over a group of letters). 

You can switch between the Character Formatting 

Controls and the Paragraph Formatting Controls, 

which sits in the same panel, by clicking the ¶ 

icon to the left of the panel. Here you can alter the 

arrangement of the text, setting the alignment of 

paragraphs, and again it offers the option to set 

indents, Drop Caps etc.

Once you are happy with the formatting of your first 

section of text, you can tell InDesign to remember 

these settings by creating a style.

Sit your type cursor within the paragraph of text 

you have formatted, then go to Window > styles > 

Paragraph styles. From the drop-down menu (click 

on the three bars at the top-right of the panel) select 

new Paragraph style. name the Style appropriately 

(e.g. Body Text or First Paragraph of Chapter), then 

click Ok.

to apply the style to other sections of text in your 

document, either insert the type cursor into the 

relevant paragraph, or highlight the bulk of text you 

want to apply the style to, and click on the style name 

in the Paragraph styles panel.

You can also set styles for individual Characters. 

For example, you might want to create an occasional 

colored, Bold, all Caps WOrD within your text. You 

can set this as a Character style in the same way you 

would a paragraph Style. go to Window > styles > 

Character styles and create a new Style, as above. 

then to apply the style, highlight relevant letters and 

click on the style name in the panel. 
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4
threading text

If you have a document with lots of text you’ll 
have to create multiple text frames. ‘threading’ 
is how you connect the frames to allow text to 
flow through them. 

Once you have created a text frame and inserted text 

into it (perhaps by Edit > Pasting from a Word doc. 

or by File > Placing the entire Word doc.) you may 

find there is too much text to sit in the frame without 

overflowing. You will see a small red + symbol at the 

bottom right-hand corner of the text frame.

the first thing to do is to set up a series of text frames 

to allow the text to flow into. Select the type tool (t) 

and drag to create new frames across the page(s) of 

your document. 

Return to the first text frame and click once on the 

+ symbol to load the cursor with text. a tiny script 

symbol will appear next to your cursor. 

Hover over the next text frame and click once inside it. 

the text will flow into the frame. Continue this process 

until all your text is contained within text frames. 

a green no errors notice will appear at the bottom left 

of the screen (from the Preflight panel) once all the 

text is visible in the document.

to view how the text frames are connected go to View 

> Extras > show text threads. In normal Mode (View 

> screen Mode > normal, or tap W on the keyboard), 

when you select a text frame, you will see the threads 

connecting the frames, showing how the text is 

ordered throughout the document.

 tOP skills tiP: Sometimes you might want to 

empty a text frame of some or all of the text that is 

overflowing. When this is book-length, highlighting 

and deleting overflowing text manually is neither 

practical or fun! place your cursor at the end of the 

section of text you want to keep, then press Ctl/Cmd-

shift-End to select all the remaining overflow text, and 

hit Delete. 
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5
Creating a Book File

If you’re creating a long document with multiple 
sections, e.g. chapters, you should create a Book 
File to better organize the large file. 

Before you create a new Document for your book 

in InDesign you should first create a separate 

Book File. a Book File brings together a number of 

different documents (e.g. you might create a separate 

document for each chapter of a Book, or section of a 

Report) into a single panel. 

the numbering system is carried forward over 

each document included in the Book File, and is 

automatically updated when you make a change. So, 

for example, if you add an extra page to Chapter 5, all 

the other later Chapters in the Book will have their 

page numbers updated accordingly.

to create a Book File, either select new...Book from 

the Welcome window when you open InDesign, or go 

to File > new > Book. You will be prompted to give the 

Book a name, and to save it in an appropriate place.

the Book will open as a small panel in InDesign. When 

you click the + icon at the bottom right of the panel, 

you will be asked to locate an InDesign document 

to add to the Book. You should create your chapter 

documents first, as basic templates, before adding 

them in the correct order to the Book. 

Be sure to include a simple page numbering system 

(see Page 5) throughout your documents. these page 

numbers will appear in the Book panel, to the right 

of the relevant chapter name. the Book File makes 

editing individual pages very simple - you can easily 

see and click on the document containing the page 

you want to edit.

When you’ve filled up your Book File with all your 

documents and are happy with the final result, you can 

Preflight the Book (check for errors) by clicking on the 

drop-down menu in the Book panel > Preflight Book. 

Once all errors have been corrected, you can export 

the Book for print by selecting Export Book to PDF... 

from the drop-down menu in the Book panel. 
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6
Page dimensions & orientation

Sometimes you will create an InDesign 
document, only to realize that you want to insert 
a page with different dimensions or orientation, 
like a pull-out page or a flipped spread. here’s 
how to do it... 

the Page tool is a super useful little tool in InDesign. 

You can find it in the tools panel running along the left 

of your screen (or Window > tools if not already open).

the Page tool allows you to select an individual page 

and redefine its dimensions. Select the Page tool and 

hover over a page in your document which you’d like 

to alter. Click once and handle-bars will appear on the 

edges of the page. 

You can drag the handles to preview a new page size 

before manually entering the dimensions of the page 

in the control panel running along the top of the 

screen. You can also define how the content currently 

on the page will sit on the new page. In the example 

here, I chose to re-center the content.

You can also switch the Orientation of a page once 

you’ve created your document. InDesign gives you 

the option of rotating the view of a selected page, 

which gives you better control when putting together 

a landscape spread within an otherwise portrait-

orientated document. 

go to the Pages Panel (Window > Pages) and click 

the three bars at the top-right of the panel to open 

the drop-down menu. With the relevant page selected 

in the Pages Panel, select Page attributes > rotate 

spread View > and select a rotation value.

 tOP skills tiP: So you’ve created a whole 

InDesign document but now your boss wants it Us 

letter size, not a4. nightmare right? Well, with a quick 

tip you can avoid a frustrating problem. 

If you go straight to File > Document setup... and edit 

page dimensions there and then, your changes will 

only take effect on the selected page. Instead, hop over 

to the Pages Panel and hold shift to click and select 

all the pages in your document. go back to File > 

Document setup..., make your edits and they will take 

effect across the whole document. 
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7
Placing & Linking images

there are some basic rules about inserting 
images in InDesign. once you’re clued up you 
can create all sorts of dynamic image-filled 
documents. 

the first key rule to remember is that images 

are Placed and linked in InDesign. they are not 

embedded, as you might do with a Word Document or 

in photoshop. 

When you Place an image, InDesign remembers the 

link to that image’s location in the relevant folder 

on your computer. this means you can work quickly 

and efficiently without dealing with a large quantity 

of heavy images slowing down your work flow. If you 

move an image to another location on your computer, 

i.e. another folder or drive, InDesign will be unable 

to locate the image and will flag up a warning in the 

Preflight panel (Window > Output > Preflight).

the second rule to remember is that InDesign places 

images within a Frame. Whether you prepare a frame 

before placing the image, or you place the image 

straight into the document (File > Place) InDesign will 

contain the image within a four-sided frame by default.

You can choose from three Frame shapes in the tools 

panel (Window > tools), rectangle, Ellipse and 

Polygon. these are marked out as different to the 

shape tools by a x shape running through the center 

of them.

Select a Frame tool, and click and drag to create a 

frame (hold shift to create a perfect shape). With the 

frame selected, go to File > Place and select an image. 

Click Open. 

You can arrange the image in the frame by double-

clicking to select the image itself within the frame (it 

will be marked by a brown line around the edges) and 

holding shift while readjusting. Or you can choose 

from the options available to you in the control panel 

which appears at the top of the screen. Fill Frame 

Proportionally is usually a good option to pick.

after inserting images, you can go to Window > links 

to view the links Panel and deal with any images that 

might be missing. these will be flagged up with a ! 

symbol. Click on the name in the panel to select the 

missing image and select the            icon to locate the 

missing image on your computer. 
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8
Swatches & color

InDesign is primarily designed for creating print 
documents, which means it works by default 
in CMyK color when you set the Intent of your 
document to Print. you should know a little 
about how InDesign translates Swatches to final 
printed colors on your document before sending 
anything to print to avoid any problems at the 
press. 

InDesign offers lots of different modes of color that you 

can use in the program, but the ones you need to know 

about are CMYk, Pantone and rgB. 

If you’re creating a document for print, you should 

always set colors as CMYk swatches, unless 

instructed directly otherwise by your printer (e.g. if 

they would recommend printing a certain color as a 

Pantone). InDesign will automatically work with CMYk 

swatches when you set the intent to Print in the new 

Document window.

to view the color swatches when you create a new 

document, go to Window > Color > swatches. a 

default set of CMYk swatches will already be available 

to you in the swatches Panel. to add a new swatch 

click on the three bars at the top-right of the panel 

to open the drop-down menu. Select new Color 

swatch... and set the Color type to Process (not 

spot, unless you want to create a spot Color layer in 

your final pDF) and Mode to CMYk. Click add, and Ok.

to apply a color to text, a shape 

or a frame in your document, 

select the element and apply 

the swatch from either the 

swatches Panel or the control 

panel running along the top 

of the screen. You can apply a 

Fill and/or a stroke color by 

switching between the two 

square symbols in the top 

control panel or at the bottom 

of the tools Panel.

to apply a tint of a color to an element, select the 

element and apply the swatch as above. In the 

swatches Panel, or from the top control panel, 

click the arrow adjacent to tint: 100% to adjust the 

saturation of color.

You can also apply a gradient effect to a colored 

element by going to Window > Color > gradient. 
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9
Proofing & Preflight

once you’ve completed your document, you can 
proof it in a similar way to how you would proof 
a Word Document, but there are additional tools 
to help ensure you have a perfected technical 
finish to your document too. 

You can conduct a word-count, character-count, 

paragraph-count and line-count using the info Panel 

(Window > info). Highlight the text to generate the 

counts.

to conduct a spell-check go to Edit > spelling > 

Check spelling to view highlighted errors. the Check 

spelling window will give you possible corrections 

for each error, and invite you to Change or skip them. 

When you’re finished, click Done. 

Before you export your document to print (see Page 

13) you should perform a Preflight to highlight any 

potential technical errors in your document. InDesign 

will alert you of any Preflight errors when you go to 

Export to pDF, but the best thing to do is open the 

Preflight Panel before exporting and go over the 

errors in detail. 

Common errors are missing fonts, text overflowing 

frames and missing links. these will be flagged up in 

red in the Preflight Panel. You can click the arrow next 

to the listed error to view more details. Ensure these 

problems are resolved before you go to export your 

document.

 tOP skills tiP: Before you even finish your 

document InDesign can help you avoid spelling errors 

as you work. You can enable Dynamic spelling, which 

underlines potential spelling mistakes as you work, 

by setting your spelling Preferences. go to Edit > 

Preferences > spelling (Windows) or inDesign > 

Preferences > spelling (Mac OS) and check Enable 

Dynamic spelling. 
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10
Exporting for print

your document’s ready and proofed, now it’s 
time to export it as a print-ready document for 
the press. read on to learn how to create a print-
ready product every time that will keep your 
printer happy... 

Different printers have different preferences for how 

they would like to receive documents for printing 

from their customers. Some provide templates, some 

specify bleed settings (see Page 4), some will request 

the native packaged InDesign files (which can be risky 

if you’d rather not have anyone alter your file) and 

some are happy to receive a print-ready pDF. 

Here we look at how you can produce the latter - a 

print-ready PDF with printer’s marks, which usually 

works a treat.

Once you’ve preflighted your document (see Page 12) 

and checked for spelling errors, you are ready to export 

for print. 

go to File > Export. You will be prompted to save the 

exported file in a location on your computer and to 

give it a name. 

From the Format drop-down options at the bottom of 

the window select 

adobe PDF (Print) 

and click save. 

In the Export 

adobe PDF 

window that 

opens, select Press 

Quality from the 

top option, adobe 

PDF Preset. this 

will create a very 

high-quality file, 

suitable for digital 

and litho printing. 

to the left of the Export adobe PDF window you will 

see a menu with a number of options. Click on Marks 

and Bleeds. 

Unless your printer has specified only some marks to 

be included, under Marks check all Printer’s Marks to 

highlight all the options below it. 

Under Bleed and slug check Use Document Bleed 

settings. If you have included a Bleed (see Page 

4), as recommended if you have any elements or 

colors which cross the edges of pages, the bleed’s 

dimensions will appear in the window. 

Click Export at the bottom right of the window (check 

the View PDF after Exporting box under general to 

view the result immediately) and you’re done! 
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